Proxmark3 community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.

"Learn the tools of the trade the hard way." +Fravia

  • Logged in as ikarus
  • Last visit: Today 11:22:42


Time changes and with it the technology
Proxmark3 @ discord

Users of this forum, please be aware that information stored on this site is not private.

#1 2023-03-12 03:17:58

Registered: 2023-02-28
Posts: 2

Usb error when booted

Hi, I'm new but I tried to read everything before asking.
I didn't solve the issue on my own so I'm writing here: I got a Proxmark3 from a friend saying it's bricked and there's nothing to do, but he also said me he hadn't done anything with it, so I tried it and it didn't work at all (it boots, turning on leds 1010 for a fraction of a second, then 0001 then only power led).

Then I tried reflashing the bootloader: plugged it in my pc holding the button, it gets recognized, I flash the bootloader and then from dmesg I see it gets disconnected and again it's not recognized (I get usb errors "device descriptor read/64, error -110" and "device not accepting address 13, error -62").

But if I tried pluggin it in holding down the button it got recongized in a few seconds, so I also tried flashing image using "client/proxmark3 /dev/ttyACM0 --flash --image armsrc/obj/fullimage.elf".
Again it flashes without any problem, when it finishes flashing the device gets disconnected (looking at dmesg) and it doesn't seem to respond correctly if I don't plug it holding the side button down.

I checked libusb but it's updated, I checked the wiki and reinstalled all the packages the client requires to work, I read the note about ModemManager and removed the package to make sure it doesn't create any issue.

Now idk how to solve this issue: I read the docs (I put particular attention to the troubleshooting section), I tried different things as I wrote before and I changed the cable just in case, but none of these things worked.

If you have any suggestion, link to a guide or a wiki I didn't read because I'm an idiot or anything that could help me make it work I'd be very happy.

I'm running Elementary OS 7, a distro based on Ubuntu 22.04 LTS, so pretty up to date.

Also, as you might have noticed, I'm not a native english speaker so please forgive me for all the mistakes I could have done writing this.

Any help is appreciated


Quick reply

Write your message and submit

Board footer

Powered by FluxBB