Proxmark3 community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.

"Learn the tools of the trade the hard way." +Fravia

  • Logged in as ikarus
  • Last visit: Today 11:22:42


Time changes and with it the technology
Proxmark3 @ discord

Users of this forum, please be aware that information stored on this site is not private.

#1 2020-12-09 04:11:41

Registered: 2020-12-08
Posts: 3

Proxmark Brew install error

Hi all,

I was having a very similar issue to a recently posted thread HERE so i tried the same and uninstalled everything and went about re-installing it using the export HOMEBREW_PROXMARK3_PLATFORM=PM3OTHER command to see if the platform change would solve my issue.

But i now seem unable to re install any version of the software from the github using homebrew regardless of the platform version. I have tried the stable and --HEAD release to see as well.

any ideas?

M-Beast:~ mike$ brew install --HEAD rfidresearchgroup/proxmark3/proxmark3
Updating Homebrew...
==> Auto-updated Homebrew!
Updated 1 tap (homebrew/core).
==> Updated Formulae
Updated 5 formulae.

==> Installing proxmark3 from rfidresearchgroup/proxmark3
==> Cloning
Cloning into '/Users/mike/Library/Caches/Homebrew/proxmark3--git'...
==> Checking out branch master
Already on 'master'
Your branch is up to date with 'origin/master'.
==> make clean
==> make all PLATFORM=PM3OTHER
Last 15 lines from /Users/mike/Library/Logs/Homebrew/proxmark3/02.make:
  "_tgoto", referenced from:
      _update_line in libreadline.a(display.o)
  "_tputs", referenced from:
      _rl_redisplay in libreadline.a(display.o)
      _update_line in libreadline.a(display.o)
      __rl_clear_to_eol in libreadline.a(display.o)
      __rl_move_vert in libreadline.a(display.o)
      __rl_move_cursor_relative in libreadline.a(display.o)
      _rl_clear_visible_line in libreadline.a(display.o)
      __rl_clear_screen in libreadline.a(display.o)
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[1]: *** [proxmark3] Error 1
make: *** [client/all] Error 2

If reporting this issue please do so at (not Homebrew/brew or Homebrew/core):

Please create pull requests instead of asking for help on Homebrew's GitHub,
Twitter or any other official channels.
M-Beast:~ mike$ 

Last edited by microspark (2020-12-09 04:17:03)


#2 2020-12-24 22:09:32

Registered: 2020-09-27
Posts: 10

Re: Proxmark Brew install error

Any luck with your install?  If you're still having problems maybe share the contents of " /Users/mike/Library/Logs/Homebrew/proxmark3/02.make".  If you'd like some real time assistance join us over on the discord server.


Quick reply

Write your message and submit

Board footer

Powered by FluxBB